mattgadient.com

Intel E2140 + ASUS P5B-VM SE overclocking

In a prior article, I was playing around with OS X installs on regular PC hardware. I’ve kept a couple of the installations going for the time being, and have been using one of them to recode some videos that we have in DivX and XviD format into H.264 for the Apple TV I recently bought.

Recoding is a time consuming process, and with this particular system, using 2-pass encoding resulted in around an hour per 1-hour episode that’s been recoded. Looking for a way to speed up the system a bit (the E2140 is known to be a pretty decent overclocker), I looked to the BIOS.

Sadly, being one of ASUS’s cheaper boards, the P5B-VM SE has very little in the way of overclocking options. That said, I’ve seen much worse. Voltage-wise, the memory can be bumped up by 0.1 volts, and that’s *it*. The multiplier however can be adjusted down (x6, x7, x8 being the options), and the FSB can be adjusted in 1Mhz intervals. PCI-Express frequency can be adjusted in 1Mhz intervals as well, and finally, memory timings are adjustable, although frequency/divider-wise there are only a few options… 533, 667, or 800. Unfortunately, I’m not sure if those frequencies correspond to dividers (in which case a strange FSB would actually result in a strange memory frequency), or if the memory timings are actually made independantly of the FSB. Had Windows still been sitting on this machine, a little testing and checking with CPU-Z would have answered that for me, but both the System Profiler and Geekbench in OS X simply reported 667Mhz regardless of whether 533 or 667Mhz was set.

My first overclocking attempt was only mildly successful. I upped the FSB from the default of 200Mhz right to 250Mhz. I couldn’t hit 260Mhz without a message popping up with a BIOS error.

A couple days later, I decided to try again. I managed to hit 266 this time. The key was in the memory setting – The section with the timings can *not* be set to “Auto” in my case. I had to manually set them. I tried jumping to 275 which didn’t work. In case there was simply a “hole” that wasn’t going to work, I cranked it up to 333 and tried again – still no go. I even bumped the multiplier down to 6x. I decided to settle on 266. As far as the memory timings go, at first I maxed them out at the highest numbers, and then worked back, finally settling on 5-5-5-10. I tried both 533 and 667 memory speeds, and neither actually made a difference in the benchmark tests I tried. If it weren’t for the 800Mhz setting causing the maching not to POST, I would have suspected that the memory frequency setting does nothing.

I ran a couple benchmarks at the default setting, as well as the overclocked setting, and got some results.

Intel E2140 and Asus P5B-VM SE Geekbench overclock results

I did the math, and found that the overclocked speed is 133% of the default. The oc’ed Geekbench score was 133.7% of the default, with individual scores ranging from 130.3-135.4%. Needless to say, it scaled very well with the overclock.

What about encoding though? I took a short music video that I had done in DivX, and recoded it to H.264.

Intel E2140 and Asus P5B-VM SE overclock encoding speeds

It took 3:47 minutes with the default setting, and 2:50 minutes with the overclocked one. Almost a full minute shorter, and 131% of the default speed, again very close to the 133% overclock, and again showing that the speed scales very well with the processor speed.

At this point, there are a few possibilities as far as bringing the FSB above 266 (and processor above 2.13Ghz) goes. I’m pretty sure the current limitation is one of the following:

  • RAM – Since the way to get the board above 250 was to change the timings from AUTO to something else, this is a strong possibility.
  • Motherboard – Lacking the voltage options would be the most likely issue if it’s the motherboard. The processor may need more juice to take a higher FSB, or it’s possible that the motherboard simply wouldn’t run that chip any faster even if it had the voltage.
  • CPU – It’s quite possible that’s the limit for the CPU. Doubtful, since when you hit a wall at the default voltage, bringing the voltage up almost always results in the ability to up the frequency some more.

In any case, an additional 31% performance when encoding is nothing to sneeze at. It basically means that I can almost encode 4 videos in the time it used to take to encode 3. And to be honest, when recoding hundreds of hours of videos… you want every last ounce of free speed you can muster.

Update: 2 days later, and I’ve tried both the voltage mod here (the same as for the E2180, bringing voltage up from 1.2 to 1.4V), as well as the BSEL mod listed on the same page (to bring to bootstrap to 266/1066. While both mods worked, I still wasn’t able to up the FSB at all. I also tried upping the PCI-E frequency to 110, 120, and 125Mhz as mentioned to work by some other people in various threads. Despite all of my efforts, there was no gain whatsoever – my motherboard seems to be limited somewhere between 266-274Mhz.

  • Advanced / CPU Configuration / CPU Ratio Setting. The default is “Auto”. If you hit the +/- keys it’ll scroll through the available options.

    If that setting isn’t available, my best guesses would be that either you need a bios update, or the cpu doesn’t support other multipliers.

  • luís gonçalves

    “The multiplier however can be adjusted down (x6, x7, x8 being the options)”

    Hi, are you sure about this? Could you please tell me the item name in the BIOS responsable for this. I have a E6400 and I can’t change multi. Maybe is CPU related. Thank you.
    kind regards.